wireless

Does the mesh protocol on the WLAN and zeroconf on WLAN/LAN interface - builds ARCMAN
Post Reply
User avatar
DD3AL
Posts: 32
Joined: Thu Oct 01, 2015 12:51 pm

wireless

Post by DD3AL » Wed Nov 11, 2015 3:26 pm

# the 2.3 GHz interface
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
# path is device specific - get it from 'wifi detect'
option path 'platform/ar934x_wmac'
option country 'DE'
# in Germany only 5 or 10 Mhz bandwith are allowed for ham Radio transmissions
option chanbw '5'
# for 2.3 GHz negative channel numbering is used (2362 MHz)
option channel '-9'
option txpower '22'

# the 2.3 GHz WLAN
config wifi-iface
option device 'radio0'
# WLAN is bridged to LAN
option network 'lan'
# encryption is not allowed for Amateur radio
option encryption 'none'
# WLAN set for IEEE802.11g ad-hoc mode
option mode 'mesh'
# the mesh id must be common between all stations
option mesh_id 'arcman'

# the 5 GHz interface
config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11a'
# path is device specific - get it from 'wifi detect'
option path 'pci0000:00/0000:00:00.0'
option htmode 'HT20'
option country 'DE'
# for 5 GHz official channel numbering is used
option channel '165'
# in Germany only 5 or 10 Mhz bandwith are allowed for ham Radio transmissions
option chanbw '10'
option txpower '0'

# the 5 GHz WLAN
config wifi-iface
option device 'radio1'
# WLAN is bridged to LAN
option network 'lan'
# WLAN set for IEEE802.11g ad-hoc mode
option mode 'mesh'
# encryption is not allowed for Amateur radio
option encryption 'none'
# the mesh id must be common between all stations
option mesh_id 'arcman'

Post Reply